$re = '/(https?:\/\/).*(@.*)/m';
$str = 'https://athenea@bitbucket.org/athenea/hm_gui.git
http://athenea@bitbucket.org/athenea/hm_gui.git';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);