package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/).*(@.*)`)
var str = `https://athenea@bitbucket.org/athenea/hm_gui.git
http://athenea@bitbucket.org/athenea/hm_gui.git`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}