import Foundation
let pattern = #"<(tag*)>(.*?)<\/\1>\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p><tag>Lorem</tag>. Excepteur sint.</p>
<p><tag>Lorem.</tag> Excepteur sint.</p>
<p><tag>Lorem ipsum</tag>. Excepteur sint.</p>
<p><tag>Lorem ipsum.</tag> Excepteur sint.</p>
<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>
<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}