const regex = /<(tag*)>(.*?)<\/\1>\./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(tag*)>(.*?)<\\\/\\1>\\.', '')
const str = `<p><tag>Lorem</tag>. Excepteur sint.</p>
<p><tag>Lorem.</tag> Excepteur sint.</p>
<p><tag>Lorem ipsum</tag>. Excepteur sint.</p>
<p><tag>Lorem ipsum.</tag> Excepteur sint.</p>
<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>
<p><tag>Lorem ipsum Excepteur</tag>. Sint.</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}