import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+> )?([^>]+)(.+)? > \\2(.+)?";
final String string = " Boating > Anchoring > Accessories > Anchors/Chain/Rope\n"
+ " Boating > Safety > Fire & Vapor Detectors > Fume Detectors\n"
+ " Clothing > Sportswear > Shirts > T-Shirts Polo\n"
+ " Gear > Knives & Tools > Knives Fixed Blade > Fixed Blade Knives\n"
+ " Hunting > Tree Stands > Accessories > Tree Stands and Accessories\n"
+ " Optics > Rings & Mounts > Scope Rings > Rings & Accessories\n"
+ " Gear > Climbing & Rappelling > Rope Cord Webbing > Rope Cord & Webbing\n\n"
+ " Fishing > Rod & Reel Combos > Rod & Reel Combos > Types of Fishing > Fishing Gear - Kids > Offshore Fishing Gear > Saltwater Fly Fishing Gear > Trolling Fishing Gear\n\n"
+ " Fishing > Lures > Hard Baits > Lures Hard Baits\n";
final String subst = "\\1\\2\\3\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}