using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+> )?([^>]+)(.+)? > \2(.+)?";
string substitution = @"\1\2\3\4";
string input = @" Boating > Anchoring > Accessories > Anchors/Chain/Rope
Boating > Safety > Fire & Vapor Detectors > Fume Detectors
Clothing > Sportswear > Shirts > T-Shirts Polo
Gear > Knives & Tools > Knives Fixed Blade > Fixed Blade Knives
Hunting > Tree Stands > Accessories > Tree Stands and Accessories
Optics > Rings & Mounts > Scope Rings > Rings & Accessories
Gear > Climbing & Rappelling > Rope Cord Webbing > Rope Cord & Webbing
Fishing > Rod & Reel Combos > Rod & Reel Combos > Types of Fishing > Fishing Gear - Kids > Offshore Fishing Gear > Saltwater Fly Fishing Gear > Trolling Fishing Gear
Fishing > Lures > Hard Baits > Lures Hard Baits
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}