#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(pa)(?!([^<]+)?>)"
Local $sString = "'The pattern to <span class="something">be replaced is pa but only outside the html tag</span>'"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)