# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(pa)(?!([^<]+)?>)//gm;t' <<< "'The pattern to <span class=\"something\">be replaced is pa but only outside the html tag</span>'"