$re = '/^000-.*/m';
$str = '000-3210
566-0001
000-589658-98979
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);