using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^000-.*";
string input = @"000-3210
566-0001
000-589658-98979
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}