re = /^(?P<ip>.*?) - - \[(?P<date>.*?)(?= ) (?P<timezone>.*?)\] \"(?P<request_method>.*?) (?P<path>.*\.php.*?)(?P<request_version> HTTP\/.*)?\" (?P<status>(301|404)?) (?P<length>.*?) \"(?P<referrer>.*?)\" \"(?P<user_agent>.*?)\"$/
str = '66.249.69.152 - - [21/Apr/2019:00:17:11 +0300] "GET /assets/files/xt9jrjx/xvzbuoq.php?uonaemsxx=top-news-widgets HTTP/1.1" 404 3713 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end