use strict;
my $str = '66.249.69.152 - - [21/Apr/2019:00:17:11 +0300] "GET /assets/files/xt9jrjx/xvzbuoq.php?uonaemsxx=top-news-widgets HTTP/1.1" 404 3713 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"';
my $regex = qr/^(?P<ip>.*?) - - \[(?P<date>.*?)(?= ) (?P<timezone>.*?)\] \"(?P<request_method>.*?) (?P<path>.*\.php.*?)(?P<request_version> HTTP/.*)?\" (?P<status>(301|404)?) (?P<length>.*?) \"(?P<referrer>.*?)\" \"(?P<user_agent>.*?)\"$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}