// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^((?'EMPTY'(""))|'(?'recipe'(\s*recipe\[\w+::\w+@((?'MAJOR'(?:0|(?:[1-9]\d*)))\.(?'MINOR'(?:0|(?:[1-9]\d*)))\.(?'PATCH'(?:0|(?:[1-9]\d*))))],*\s*))+')$"#).unwrap();
let string = "\"\"
\"\" <-- Empty
'recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[s::s@1.0.0]'
'recipe[COOKBOOK::RECIPE_NAME@1.0.0]'
'recipe[COOKBOOK::RECIPE_NAME@1.0.0], recipe[COOKBOOK::RECIPE_NAME@1.0.0]'
'recipe[COOKBOOK::RECIPE_NAME@11.10.10], recipe[COOKBOOK::RECIPE_NAME@11.10.10]'
'recipe[COOKBOOK::RECIPE_NAME@11.10.10]'
'recipe[cookbook::recipe]'
'recipe[somestring]'
'recipe[cookbook@1.0.0]'
'recipe[cookbook::recipe_name@1.0.0]'
'bsad'
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}