re = /^((?'EMPTY'(""))|'(?'recipe'(\s*recipe\[\w+::\w+@((?'MAJOR'(?:0|(?:[1-9]\d*)))\.(?'MINOR'(?:0|(?:[1-9]\d*)))\.(?'PATCH'(?:0|(?:[1-9]\d*))))],*\s*))+')$/m
str = '""
"" <-- Empty
\'recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[s::s@1.0.0]\'
\'recipe[COOKBOOK::RECIPE_NAME@1.0.0]\'
\'recipe[COOKBOOK::RECIPE_NAME@1.0.0], recipe[COOKBOOK::RECIPE_NAME@1.0.0]\'
\'recipe[COOKBOOK::RECIPE_NAME@11.10.10], recipe[COOKBOOK::RECIPE_NAME@11.10.10]\'
\'recipe[COOKBOOK::RECIPE_NAME@11.10.10]\'
\'recipe[cookbook::recipe]\'
\'recipe[somestring]\'
\'recipe[cookbook@1.0.0]\'
\'recipe[cookbook::recipe_name@1.0.0]\'
\'bsad\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end