const regex = /^([\-ld])(([\-r][\-w][\-xs]){3})\s+(\d+)\s+(\w+)\s+(\w+)\s+(\d+)\s+(((\w{3})\s+(\d{2})\s+(\d{1,2}):(\d{2}))|((\w{3})\s+(\d{2})\s+(\d{4})))\s+(.+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\-ld])(([\\-r][\\-w][\\-xs]){3})\\s+(\\d+)\\s+(\\w+)\\s+(\\w+)\\s+(\\d+)\\s+(((\\w{3})\\s+(\\d{2})\\s+(\\d{1,2}):(\\d{2}))|((\\w{3})\\s+(\\d{2})\\s+(\\d{4})))\\s+(.+)$', '')
const str = `-rw-r--r-- 1 1089 1091 505482 Nov 19 22:53 paper texture 2jpg1290206009609589.JPG `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}