package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\-ld])(([\-r][\-w][\-xs]){3})\s+(\d+)\s+(\w+)\s+(\w+)\s+(\d+)\s+(((\w{3})\s+(\d{2})\s+(\d{1,2}):(\d{2}))|((\w{3})\s+(\d{2})\s+(\d{4})))\s+(.+)$`)
var str = `-rw-r--r-- 1 1089 1091 505482 Nov 19 22:53 paper texture 2jpg1290206009609589.JPG `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}