import Foundation
let pattern = #"IO::Memory(O|I)Channel(|32)([\s]|::|&[\s]|\*[\s])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
GS::MemoryOChannel32 oBuffer (IO::MemoryOChannel32::BMAllocation);
BinIProtocol.hpp
BinOProtocol.hpp
InputBuffer.hpp
OutputBuffer.hpp
IChannelAdapter.hpp
OChannelAdapter.hpp
MemoryIChannel.hpp
MemoryIChannel32.hpp
MemoryOChannel.hpp
MemoryOChannel32.hpp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)