using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"IO::Memory(O|I)Channel(|32)([\s]|::|&[\s]|\*[\s])";
string input = @" GS::MemoryOChannel32 oBuffer (IO::MemoryOChannel32::BMAllocation);
BinIProtocol.hpp
BinOProtocol.hpp
InputBuffer.hpp
OutputBuffer.hpp
IChannelAdapter.hpp
OChannelAdapter.hpp
MemoryIChannel.hpp
MemoryIChannel32.hpp
MemoryOChannel.hpp
MemoryOChannel32.hpp";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}