$re = '/(^|\D)\b5\d{8}($|\D)/m';
$str = 'C 500420074 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);