package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\D)\b5\d{8}($|\D)`)
var str = `C 500420074 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}