re = /(('[a-zA-Z0-9, &-]+'!)|([a-zA-Z, &-]+!))?(((\$?[a-zA-Z]{1,3}\$?[0-9]+#?)(:\$?[a-zA-Z]{1,3}\$?[0-9]+)?)|(\$?[a-zA-Z]{1,3}:\$?[a-zA-Z]{1,3})|(\$?[0-9]+:\$?[0-9]+))/m
str = '\'`-=[]\\;\'\',./~!@#$%^&*()_+{}|:"<>?\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end