package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(('[a-zA-Z0-9, &-]+'!)|([a-zA-Z, &-]+!))?(((\$?[a-zA-Z]{1,3}\$?[0-9]+#?)(:\$?[a-zA-Z]{1,3}\$?[0-9]+)?)|(\$?[a-zA-Z]{1,3}:\$?[a-zA-Z]{1,3})|(\$?[0-9]+:\$?[0-9]+))`)
var str = `'\`-=[]\;'',./~!@#$%^&*()_+{}|:"<>?'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}