import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(my date of birth is|my birthdate is|my birthday is|my bday is|i was born on|date of birth is|dob is|birthdate is|my dob is|birthday|birth date is)*(\\s)*(((0)[0-9])|((1)[0-2])|(January|Jan|February|Feb|March|Mar|April|Apr|May|June|Jun|July|Jul|August|Aug|September|Sep|October|Oct|November|Nov|December|Dec))(\\/|.|-)([0-2][0-9]|(3)[0-1])(\\/|.|-)\\d{2,4}";
final String string = "1. dob is 12-19-1994\n"
+ "2. 1234\n"
+ "3. 4567\n"
+ "4. 09/19/1993\n"
+ "5. Mar 14 1954\n"
+ "6. asd \n"
+ "7. dob is 12-12-1234\n"
+ "8. 4456\n"
+ "9. 352345\n"
+ "12345678\n"
+ "09-19-1993\n"
+ "09.19.1993\n"
+ "\"09.19.1993\"\n"
+ "january 10 2021\n"
+ "09191993";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}