#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(my date of birth is|my birthdate is|my birthday is|my bday is|i was born on|date of birth is|dob is|birthdate is|my dob is|birthday|birth date is)*(\s)*(((0)[0-9])|((1)[0-2])|(January|Jan|February|Feb|March|Mar|April|Apr|May|June|Jun|July|Jul|August|Aug|September|Sep|October|Oct|November|Nov|December|Dec))(\/|.|-)([0-2][0-9]|(3)[0-1])(\/|.|-)\d{2,4}"
Local $sString = "1. dob is 12-19-1994" & @CRLF & _
"2. 1234" & @CRLF & _
"3. 4567" & @CRLF & _
"4. 09/19/1993" & @CRLF & _
"5. Mar 14 1954" & @CRLF & _
"6. asd " & @CRLF & _
"7. dob is 12-12-1234" & @CRLF & _
"8. 4456" & @CRLF & _
"9. 352345" & @CRLF & _
"12345678" & @CRLF & _
"09-19-1993" & @CRLF & _
"09.19.1993" & @CRLF & _
""09.19.1993"" & @CRLF & _
"january 10 2021" & @CRLF & _
"09191993"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)