re = /.*[Product|product]\":\"([^\"]+).*/m
str = '{"Product":"BNZ Kiwisaver Scheme"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end