package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[Product|product]\":\"([^\"]+).*`)
var str = `{"Product":"BNZ Kiwisaver Scheme"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}