import Foundation
let pattern = #"<?[^<>]*>|<[^>]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Strip all HTML tags from a string. HTML tags are enclosed in < and >.
The regex will be applied on a line-by-line basis, meaning partial tags will need to be handled by the regex. Don't worry about opening or closing tags; we just want to get rid of them all.
Note: This task is meant to be a learning exercise, and not necessarily the best way to parse HTML
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)