package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<?[^<>]*>|<[^>]*`)
var str = `Strip all HTML tags from a string. HTML tags are enclosed in < and >.
The regex will be applied on a line-by-line basis, meaning partial tags will need to be handled by the regex. Don't worry about opening or closing tags; we just want to get rid of them all.
Note: This task is meant to be a learning exercise, and not necessarily the best way to parse HTML`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}