use strict;
my $str = '192.168.0.1:90000/ubuntu/kek@sha256:45b23dee08af5e43a7fea6c4cf9c25ccf269ee113168c19722f87876677c5cb2';
my $regex = qr/^(:(=[^:\/]{4,253})(?!-)[a-zA-Z0-9-]{1,63}(?<!-)(?:\.(?!-)[a-zA-Z0-9-]{1,63}(?<!-))*(?::[0-9]{1,5})?\/)?(?<image>(?![._-])(?:(?:[a-z0-9._-]*(?::[0-9]{1,5})?))(?<![._-])(?:\/(?![._-])[a-z0-9._-]*(?<![._-]))*)(?:(?<tag>(?::(?![.-])[a-zA-Z0-9_.-]{1,128}))|(?<sha>@sha256:[0-9a-f]{64}))?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}