const regex = /^(:(=[^:\/]{4,253})(?!-)[a-zA-Z0-9-]{1,63}(?<!-)(?:\.(?!-)[a-zA-Z0-9-]{1,63}(?<!-))*(?::[0-9]{1,5})?\/)?(?<image>(?![._-])(?:(?:[a-z0-9._-]*(?::[0-9]{1,5})?))(?<![._-])(?:\/(?![._-])[a-z0-9._-]*(?<![._-]))*)(?:(?<tag>(?::(?![.-])[a-zA-Z0-9_.-]{1,128}))|(?<sha>@sha256:[0-9a-f]{64}))?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(:(=[^:\\\/]{4,253})(?!-)[a-zA-Z0-9-]{1,63}(?<!-)(?:\\.(?!-)[a-zA-Z0-9-]{1,63}(?<!-))*(?::[0-9]{1,5})?\\\/)?(?<image>(?![._-])(?:(?:[a-z0-9._-]*(?::[0-9]{1,5})?))(?<![._-])(?:\\\/(?![._-])[a-z0-9._-]*(?<![._-]))*)(?:(?<tag>(?::(?![.-])[a-zA-Z0-9_.-]{1,128}))|(?<sha>@sha256:[0-9a-f]{64}))?$', '')
const str = `192.168.0.1:90000/ubuntu/kek@sha256:45b23dee08af5e43a7fea6c4cf9c25ccf269ee113168c19722f87876677c5cb2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}