re = /^((1?[\d]?[\d]|2([0-4][\d]|5[0-5]))[.]){3}(1?[\d]?[\d]|2([0-4][\d]|5[0-5]))$/
str = '10.0.0.30'
# Print the match result
str.match(re) do |match|
puts match.to_s
end