const regex = /^((1?[\d]?[\d]|2([0-4][\d]|5[0-5]))[.]){3}(1?[\d]?[\d]|2([0-4][\d]|5[0-5]))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((1?[\\d]?[\\d]|2([0-4][\\d]|5[0-5]))[.]){3}(1?[\\d]?[\\d]|2([0-4][\\d]|5[0-5]))$', '')
const str = `10.0.0.30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}