re = /\((\w+)(\w+)?\)/
str = ' /* # combined # TargetLink outport: SWC_ClutchControlCC/lib_SWC_CC02/S_iBLDCSetPnt */
Rte_Write_SP_ClutchCtrlC02_S_iBLDCSetPnt(V_SpdCtrlC02_iBLDCSetPnt);
Rte_Write_SP_ClutchCtrlC02_S_iBLDCSetPnt((int) V_SpdCtrlC02_iBLDCSetPnt);
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end