use strict;
my $str = ' /* # combined # TargetLink outport: SWC_ClutchControlCC/lib_SWC_CC02/S_iBLDCSetPnt */
Rte_Write_SP_ClutchCtrlC02_S_iBLDCSetPnt(V_SpdCtrlC02_iBLDCSetPnt);
Rte_Write_SP_ClutchCtrlC02_S_iBLDCSetPnt((int) V_SpdCtrlC02_iBLDCSetPnt);
';
my $regex = qr/\((\w+)(\w+)?\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}