const regex = /^(?:[a-z0-9]+)\/(?:(?:v(?:10|\d)\.[0-9]{1,2}\.[0-9]{1,2})|week[0-9]{1,2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-z0-9]+)\\\/(?:(?:v(?:10|\\d)\\.[0-9]{1,2}\\.[0-9]{1,2})|week[0-9]{1,2})$', 'gm')
const str = `bqcloud/v1.0.0
becloud/v1.0.0
dfx37/v1.0.1
dfx37cloud/v9.11.6
dfx37/week12
dfx37/v1.0.0
bxc53fb/v1.0.0
feature/BXC53FB/test
feature/BECLOUD-1/test
feature/BQCLOUD-1/lf
feature/BE21CLOUD-1/test
feature/DFX37-37/dftest
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}