#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[a-z0-9]+)\/(?:(?:v(?:10|\d)\.[0-9]{1,2}\.[0-9]{1,2})|week[0-9]{1,2})$"
Local $sString = "bqcloud/v1.0.0" & @CRLF & _
"becloud/v1.0.0" & @CRLF & _
"dfx37/v1.0.1" & @CRLF & _
"dfx37cloud/v9.11.6" & @CRLF & _
"dfx37/week12" & @CRLF & _
"" & @CRLF & _
"dfx37/v1.0.0" & @CRLF & _
"bxc53fb/v1.0.0" & @CRLF & _
"" & @CRLF & _
"feature/BXC53FB/test" & @CRLF & _
"feature/BECLOUD-1/test" & @CRLF & _
"feature/BQCLOUD-1/lf" & @CRLF & _
"" & @CRLF & _
"feature/BE21CLOUD-1/test" & @CRLF & _
"feature/DFX37-37/dftest" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")