use strict;
my $str = ' this is something ';
my $regex = qr/^\s+|\s+$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";