package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s+|\s+$`)
var str = ` this is something `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}