re = /(?i)\bflirt[\wá-ú]+/
str = 'Palabras que empiezan con flirte 13 letras:
flirtearÃamos,
Palabras que empiezan con flirte 12 letras:
flirteasteis, flirtearemos, flirteáramos, flirteábamos, flirteáremos, flirteásemos, flirtearÃais,
Palabras que empiezan con flirte 11 letras:
flirtearÃan, flirtearéis, flirtearÃas, flirteareis, flirteaseis, flirtearais, flirteabais,
Palabras que empiezan con flirte 10 letras:
flirteemos, flirtearán, flirtearás, flirteases, flirteados, flirtearÃa, flirteabas, flirteaban, flirteasen, flirteaste, flirtearse, flirtearan, flirtearas, flirteando, flirteamos, flirtearen, flirteares, flirtearon, flirteadas,
Palabras que empiezan con flirte 9 letras:
flirteáis, flirteéis, flirteara, flirtease, flirteado, flirteada, flirteaba, flirteare, flirteará, flirtearé:
Palabras que empiezan con flirte 8 letras:
flirteas, flirtean, flirtear, flirteos, flirtead, flirtees, flirteen,
Palabras que empiezan con flirte 7 letras:
flirteé, flirteo, flirtea, flirtee, flirteó,'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result