import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\bflirt[\\wá-ú]+";
final String string = "Palabras que empiezan con flirte 13 letras:\n"
+ "flirtearÃamos,\n"
+ "Palabras que empiezan con flirte 12 letras:\n"
+ "flirteasteis, flirtearemos, flirteáramos, flirteábamos, flirteáremos, flirteásemos, flirtearÃais,\n"
+ "Palabras que empiezan con flirte 11 letras:\n"
+ "flirtearÃan, flirtearéis, flirtearÃas, flirteareis, flirteaseis, flirtearais, flirteabais,\n"
+ "Palabras que empiezan con flirte 10 letras:\n"
+ "flirteemos, flirtearán, flirtearás, flirteases, flirteados, flirtearÃa, flirteabas, flirteaban, flirteasen, flirteaste, flirtearse, flirtearan, flirtearas, flirteando, flirteamos, flirtearen, flirteares, flirtearon, flirteadas,\n"
+ "Palabras que empiezan con flirte 9 letras:\n"
+ "flirteáis, flirteéis, flirteara, flirtease, flirteado, flirteada, flirteaba, flirteare, flirteará, flirtearé:\n"
+ "Palabras que empiezan con flirte 8 letras:\n"
+ "flirteas, flirtean, flirtear, flirteos, flirtead, flirtees, flirteen,\n"
+ "Palabras que empiezan con flirte 7 letras:\n"
+ "flirteé, flirteo, flirtea, flirtee, flirteó,";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}