re = /(?<=.).(?=[^@]*?.@)|(?:(?<=@.)|(?!^)\G(?=[^@]*$))(.)(?=.*\.)|(?:(?<=\.)(?=[^.]+$)|(?!^)\G(?=[^@.]*$))[^.](?!$)/m
str = 'john.travolta@gmail.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result