const regex = /(?<=.).(?=[^@]*?.@)|(?:(?<=@.)|(?!^)\G(?=[^@]*$))(.)(?=.*\.)|(?:(?<=\.)(?=[^.]+$)|(?!^)\G(?=[^@.]*$))[^.](?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=.).(?=[^@]*?.@)|(?:(?<=@.)|(?!^)\\G(?=[^@]*$))(.)(?=.*\\.)|(?:(?<=\\.)(?=[^.]+$)|(?!^)\\G(?=[^@.]*$))[^.](?!$)', 'gm')
const str = `john.travolta@gmail.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);