use strict;
my $str = '/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20130717-053058.jpa
/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20140707-145230.jpa
/var/www/u4534146/data/www/xn--80adpfjfv6e5c.xn--p1ai/administrator/components/com_akeeba/backup/site-www.xn--80adpfjfv6e5c.xn--p1ai-20140707-141309.jpa
/var/www/u4551186/data/www/lovozero.net/administrator/components/com_akeeba/backup/site-lovozero.net-20140506-182906.jpa
/var/www/u4551186/data/www/lovozero.net/administrator/components/com_akeeba/backup/site-lovozero.net-20140721-091725.jpa
/var/www/u4551186/data/www/ruslapland.com/administrator/components/com_akeeba/backup/site-ruslapland.com-20140505-055235.jpa
/var/www/u4656806/data/www/flowerskhv.ru/administrator/components/com_akeeba/backup/site-flowerskhv.ru-20130801-083230.zip
/var/www/u4656806/data/www/flowerskhv.ru/administrator/components/com_akeeba/backup/site-flowerskhv.ru-20130801-080342.jpa
/var/www/u4763625/data/www/spbkk.org/administrator/components/com_akeeba/backup/site-www.spbkk.org-20131202-081827.z01
/var/www/u6412275/data/www/keramicheskaya-cherepitsa.ru/administrator/components/com_akeeba/backup/site-koramic7.ru-20140615-113953.zip
/var/www/u6412275/data/www/keramicheskaya-cherepitsa.ru/administrator/components/com_akeeba/backup/site-koramic7.ru-20140615-115049.zip
/var/www/u6559515/data/www/division.nnov.ru/administrator/components/com_akeeba/backup/site-division.nnov.ru-20130814-124501.jpa
/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131004-051700.jpa
/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131001-103321.jpa
/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20130918-132300.jpa
/var/www/u7357881/data/www/www.na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131004-051700.jpa
/var/www/u7357881/data/www/www.na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131001-103321.jpa
/var/www/u7357881/data/www/www.na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20130918-132300.jpa
/var/www/u7726504/data/www/injinterior.com/administrator/components/com_akeeba/backup/site-injinterior.com-20131002-163453.zip
[root@server41 ~]# find /var/www/*/data/www/*/administrator/components/com_akeeba/backup/ -size +50M -type f -regextype posix-extended -regex \'.+20[0-9].+\'
/var/www/u0017144/data/www/camper.diamonds/administrator/components/com_akeeba/backup/site-camper.diamonds-20140702-232727.jpa
/var/www/u0017144/data/www/camper.diamonds/administrator/components/com_akeeba/backup/site-camper.diamonds-20140703-115210.jpa
/var/www/u0017144/data/www/camper.diamonds/administrator/components/com_akeeba/backup/site-camper.diamonds-20140703-095129.jpa
/var/www/u3669070/data/www/empyrio.com/administrator/components/com_akeeba/backup/site-empyrio.com-20130531-180641.zip
/var/www/u3669070/data/www/empyrio.com/administrator/components/com_akeeba/backup/site-empyrio.com-20130706-065422.zip
/var/www/u3669070/data/www/empyrio.com/administrator/components/com_akeeba/backup/site-empyrio.com-20130511-104029.zip
/var/www/u3671785/data/www/coffeetehnika.ru/administrator/components/com_akeeba/backup/site-coffeetehnika.ru-20140701-134919.jpa
/var/www/u3671785/data/www/www.coffeetehnika.ru/administrator/components/com_akeeba/backup/site-coffeetehnika.ru-20140701-134919.jpa
/var/www/u3677644/data/www/lea/administrator/components/com_akeeba/backup/site-www.luxury-escort-agency.ru-20130524-133127.jpa
/var/www/u3704435/data/www/spacegiraffe.ru/administrator/components/com_akeeba/backup/site-spacegiraffe.ru-20120321-150956.jpa
/var/www/u3708456/data/www/astron-fit.ru/administrator/components/com_akeeba/backup/site-astron-fit.ru-20121015-123938.jpa
/var/www/u3708456/data/www/astron-fit.ru/administrator/components/com_akeeba/backup/site-astron-fit.ru-20130225-140418.jpa
/var/www/u4409328/data/www/logitechstore.ru/administrator/components/com_akeeba/backup/site-logitechstore.ru-20140720-145007.zip
/var/www/u4534146/data/www/100-89.ru/administrator/components/com_akeeba/backup/site-100-89.ru-20140611-205311.jpa
/var/www/u4534146/data/www/100-89.ru/administrator/components/com_akeeba/backup/site-100-89.ru-20140611-211200.jpa
/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20130717-054930.jpa
/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20140218-061451.jpa
/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20130717-053058.jpa
/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20140707-145230.jpa
/var/www/u4534146/data/www/xn--80adpfjfv6e5c.xn--p1ai/administrator/components/com_akeeba/backup/site-www.xn--80adpfjfv6e5c.xn--p1ai-20140707-141309.jpa
/var/www/u4551186/data/www/lovozero.net/administrator/components/com_akeeba/backup/site-lovozero.net-20140506-182906.jpa
/var/www/u4551186/data/www/lovozero.net/administrator/components/com_akeeba/backup/site-lovozero.net-20140721-091725.jpa
/var/www/u4551186/data/www/ruslapland.com/administrator/components/com_akeeba/backup/site-ruslapland.com-20140505-055235.jpa
/var/www/u4656806/data/www/flowerskhv.ru/administrator/components/com_akeeba/backup/site-flowerskhv.ru-20130801-083230.zip
/var/www/u4656806/data/www/flowerskhv.ru/administrator/components/com_akeeba/backup/site-flowerskhv.ru-20130801-080342.jpa
/var/www/u4763625/data/www/spbkk.org/administrator/components/com_akeeba/backup/site-www.spbkk.org-20131202-081827.z01
/var/www/u6412275/data/www/keramicheskaya-cherepitsa.ru/administrator/components/com_akeeba/backup/site-koramic7.ru-20140615-113953.zip
/var/www/u6412275/data/www/keramicheskaya-cherepitsa.ru/administrator/components/com_akeeba/backup/site-koramic7.ru-20140615-115049.zip
/var/www/u6559515/data/www/division.nnov.ru/administrator/components/com_akeeba/backup/site-division.nnov.ru-20130814-124501.jpa
/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131004-051700.jpa
/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131001-103321.jpa
/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20130918-132300.jpa';
my $regex = qr/(2014[0-5]{2}|20[0-3]{2}[0-9]{2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}