import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(2014[0-5]{2}|20[0-3]{2}[0-9]{2})";
final String string = "/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20130717-053058.jpa\n"
+ "/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20140707-145230.jpa\n"
+ "/var/www/u4534146/data/www/xn--80adpfjfv6e5c.xn--p1ai/administrator/components/com_akeeba/backup/site-www.xn--80adpfjfv6e5c.xn--p1ai-20140707-141309.jpa\n"
+ "/var/www/u4551186/data/www/lovozero.net/administrator/components/com_akeeba/backup/site-lovozero.net-20140506-182906.jpa\n"
+ "/var/www/u4551186/data/www/lovozero.net/administrator/components/com_akeeba/backup/site-lovozero.net-20140721-091725.jpa\n"
+ "/var/www/u4551186/data/www/ruslapland.com/administrator/components/com_akeeba/backup/site-ruslapland.com-20140505-055235.jpa\n"
+ "/var/www/u4656806/data/www/flowerskhv.ru/administrator/components/com_akeeba/backup/site-flowerskhv.ru-20130801-083230.zip\n"
+ "/var/www/u4656806/data/www/flowerskhv.ru/administrator/components/com_akeeba/backup/site-flowerskhv.ru-20130801-080342.jpa\n"
+ "/var/www/u4763625/data/www/spbkk.org/administrator/components/com_akeeba/backup/site-www.spbkk.org-20131202-081827.z01\n"
+ "/var/www/u6412275/data/www/keramicheskaya-cherepitsa.ru/administrator/components/com_akeeba/backup/site-koramic7.ru-20140615-113953.zip\n"
+ "/var/www/u6412275/data/www/keramicheskaya-cherepitsa.ru/administrator/components/com_akeeba/backup/site-koramic7.ru-20140615-115049.zip\n"
+ "/var/www/u6559515/data/www/division.nnov.ru/administrator/components/com_akeeba/backup/site-division.nnov.ru-20130814-124501.jpa\n"
+ "/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131004-051700.jpa\n"
+ "/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131001-103321.jpa\n"
+ "/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20130918-132300.jpa\n"
+ "/var/www/u7357881/data/www/www.na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131004-051700.jpa\n"
+ "/var/www/u7357881/data/www/www.na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131001-103321.jpa\n"
+ "/var/www/u7357881/data/www/www.na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20130918-132300.jpa\n"
+ "/var/www/u7726504/data/www/injinterior.com/administrator/components/com_akeeba/backup/site-injinterior.com-20131002-163453.zip\n"
+ "[root@server41 ~]# find /var/www/*/data/www/*/administrator/components/com_akeeba/backup/ -size +50M -type f -regextype posix-extended -regex '.+20[0-9].+'\n"
+ "/var/www/u0017144/data/www/camper.diamonds/administrator/components/com_akeeba/backup/site-camper.diamonds-20140702-232727.jpa\n"
+ "/var/www/u0017144/data/www/camper.diamonds/administrator/components/com_akeeba/backup/site-camper.diamonds-20140703-115210.jpa\n"
+ "/var/www/u0017144/data/www/camper.diamonds/administrator/components/com_akeeba/backup/site-camper.diamonds-20140703-095129.jpa\n"
+ "/var/www/u3669070/data/www/empyrio.com/administrator/components/com_akeeba/backup/site-empyrio.com-20130531-180641.zip\n"
+ "/var/www/u3669070/data/www/empyrio.com/administrator/components/com_akeeba/backup/site-empyrio.com-20130706-065422.zip\n"
+ "/var/www/u3669070/data/www/empyrio.com/administrator/components/com_akeeba/backup/site-empyrio.com-20130511-104029.zip\n"
+ "/var/www/u3671785/data/www/coffeetehnika.ru/administrator/components/com_akeeba/backup/site-coffeetehnika.ru-20140701-134919.jpa\n"
+ "/var/www/u3671785/data/www/www.coffeetehnika.ru/administrator/components/com_akeeba/backup/site-coffeetehnika.ru-20140701-134919.jpa\n"
+ "/var/www/u3677644/data/www/lea/administrator/components/com_akeeba/backup/site-www.luxury-escort-agency.ru-20130524-133127.jpa\n"
+ "/var/www/u3704435/data/www/spacegiraffe.ru/administrator/components/com_akeeba/backup/site-spacegiraffe.ru-20120321-150956.jpa\n"
+ "/var/www/u3708456/data/www/astron-fit.ru/administrator/components/com_akeeba/backup/site-astron-fit.ru-20121015-123938.jpa\n"
+ "/var/www/u3708456/data/www/astron-fit.ru/administrator/components/com_akeeba/backup/site-astron-fit.ru-20130225-140418.jpa\n"
+ "/var/www/u4409328/data/www/logitechstore.ru/administrator/components/com_akeeba/backup/site-logitechstore.ru-20140720-145007.zip\n"
+ "/var/www/u4534146/data/www/100-89.ru/administrator/components/com_akeeba/backup/site-100-89.ru-20140611-205311.jpa\n"
+ "/var/www/u4534146/data/www/100-89.ru/administrator/components/com_akeeba/backup/site-100-89.ru-20140611-211200.jpa\n"
+ "/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20130717-054930.jpa\n"
+ "/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20140218-061451.jpa\n"
+ "/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20130717-053058.jpa\n"
+ "/var/www/u4534146/data/www/nordfarm89.ru/administrator/components/com_akeeba/backup/site-nordfarm89.ru-20140707-145230.jpa\n"
+ "/var/www/u4534146/data/www/xn--80adpfjfv6e5c.xn--p1ai/administrator/components/com_akeeba/backup/site-www.xn--80adpfjfv6e5c.xn--p1ai-20140707-141309.jpa\n"
+ "/var/www/u4551186/data/www/lovozero.net/administrator/components/com_akeeba/backup/site-lovozero.net-20140506-182906.jpa\n"
+ "/var/www/u4551186/data/www/lovozero.net/administrator/components/com_akeeba/backup/site-lovozero.net-20140721-091725.jpa\n"
+ "/var/www/u4551186/data/www/ruslapland.com/administrator/components/com_akeeba/backup/site-ruslapland.com-20140505-055235.jpa\n"
+ "/var/www/u4656806/data/www/flowerskhv.ru/administrator/components/com_akeeba/backup/site-flowerskhv.ru-20130801-083230.zip\n"
+ "/var/www/u4656806/data/www/flowerskhv.ru/administrator/components/com_akeeba/backup/site-flowerskhv.ru-20130801-080342.jpa\n"
+ "/var/www/u4763625/data/www/spbkk.org/administrator/components/com_akeeba/backup/site-www.spbkk.org-20131202-081827.z01\n"
+ "/var/www/u6412275/data/www/keramicheskaya-cherepitsa.ru/administrator/components/com_akeeba/backup/site-koramic7.ru-20140615-113953.zip\n"
+ "/var/www/u6412275/data/www/keramicheskaya-cherepitsa.ru/administrator/components/com_akeeba/backup/site-koramic7.ru-20140615-115049.zip\n"
+ "/var/www/u6559515/data/www/division.nnov.ru/administrator/components/com_akeeba/backup/site-division.nnov.ru-20130814-124501.jpa\n"
+ "/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131004-051700.jpa\n"
+ "/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20131001-103321.jpa\n"
+ "/var/www/u7357881/data/www/na-odo.ru/administrator/components/com_akeeba/backup/site-na-odo.ru-20130918-132300.jpa";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}