import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?![a-zA-Z\\d_])|\\.|^)(iscord\\.gift)(?:(?![a-zA-Z\\d_.]))";
final String string = "discord.gift\n"
+ "cdn.discord.gift\n"
+ "iscord.gift\n"
+ "cdn.iscord.gift daw";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}