using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?![a-zA-Z\d_])|\.|^)(iscord\.gift)(?:(?![a-zA-Z\d_.]))";
string input = @"discord.gift
cdn.discord.gift
iscord.gift
cdn.iscord.gift daw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}