$re = '/^.*(?:\..*){2,}$/m';
$str = 'stCommonData.machine.machineVersion
stRieterStdPermanentData.constructionYear
stPDInfoData.SW.REG.str80SoftwVersString';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);