package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(?:\..*){2,}$`)
var str = `stCommonData.machine.machineVersion
stRieterStdPermanentData.constructionYear
stPDInfoData.SW.REG.str80SoftwVersString`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}