import Foundation
let pattern = ##"""
^((?<ShowNameA>.*[^ (_.]) [ (_.]+ (?!720p|1080p|264|265)
(
# Shows with preceding Year
#(?<ShowYearA>\d{4}) ([ (_.]+ (
(?<ShowYearA>(?:19|20)\d{2}) ([ (_.]+ (
(?<SeasonA>\d{1,2})x(?<EpisodeA>\d{1,2})
|(?<SeasonB>[0-3]?[0-9])(?<EpisodeB>\d{2})
|S(?<SeasonC>\d{1,2})E(?<EpisodeC>\d{1,2}) ) )?
| # Shows without preceding Year
(?<!\d{4})(
S(?<SeasonD>\d{1,2})E(?<EpisodeD>\d{1,2})
|(?<SeasonF>[0-3]?[0-9])(?<EpisodeF>\d{2})
|(?<SeasonE>\d{1,2})x(?<EpisodeE>\d{1,2}))
)
|(?<ShowNameB>.+))
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
666.Park.Avenue.S01E04.HDTV.x264-LOL.[VTV].mp4
Rick and Morty S01E01 - Pilot [1080p] [h.265].mkv
The.4400.204.mkv
The Flash (2014) - S01E05 - City of Heroes
family.guy.1316.hdtv-lol.mp4
castle.2009.722.hdtv-lol.mp4
Orange.Is.The.New.Black.S01E01.720p.WEBRip.AAC2.0.H.264-Abjex.mkv
Top.Gear.2013.20x03.720p.HDTV.x264-FoV.mkv
archer.2009.S04E13
louie.506.hdtv-lol.mp4
Sense8.S01E05.Art.Is.Like.Religion.WEBRip.x264-SNEAkY.mp4
The.Leftovers.S01E03.HDTV.x264-KILLERS.mp4
space 1999 1975
Top.Gear.20x03.720p.HDTV.x264-FoV.mkv
Space: 1999 (1975)
Space.1999.1975.S01E01
marvels.agents.of.s.h.i.e.l.d.s01e13.720p.hdtv.x264-killers.mkv
Supernatural.S10E12.720p.HDTV.X264-DIMENSION.mkv
12.Monkeys.S01E09.720p.HDTV.x264-KILLERS.mkv
space 1999.(1975)
Space.1999.S01E01
v.2009.S01E13.the.title.avi
Teen.wolf.S04E12.HDTV.x264
The Newsroom 2X04 Conseguenze Indesiderate ITA ENG BDMux -iGM+GiuseppeTnT mkv
Continuum S04E01 Lost Hours -LGC mkv
Royal Pains S07E04 HEVC piemonster mkv
Sense8.S01E05.Art.Is.Like.Religion.WEBRip.x264-SNEAkY.mp4
Family.Guy.S11.Special-200.Episodes.Later.720p.HDTV.X264-DIMENSION
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)