import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?<ShowNameA>.*[^ (_.]) [ (_.]+ (?!720p|1080p|264|265)\n"
+ "(\n"
+ "# Shows with preceding Year\n"
+ "#(?<ShowYearA>\\d{4}) ([ (_.]+ ( \n"
+ "(?<ShowYearA>(?:19|20)\\d{2}) ([ (_.]+ ( \n"
+ "(?<SeasonA>\\d{1,2})x(?<EpisodeA>\\d{1,2})\n"
+ "|(?<SeasonB>[0-3]?[0-9])(?<EpisodeB>\\d{2})\n"
+ "|S(?<SeasonC>\\d{1,2})E(?<EpisodeC>\\d{1,2}) ) )? \n\n"
+ "| # Shows without preceding Year\n"
+ " (?<!\\d{4})(\n"
+ "S(?<SeasonD>\\d{1,2})E(?<EpisodeD>\\d{1,2})\n"
+ "|(?<SeasonF>[0-3]?[0-9])(?<EpisodeF>\\d{2})\n"
+ "|(?<SeasonE>\\d{1,2})x(?<EpisodeE>\\d{1,2}))\n\n"
+ ")\n"
+ "|(?<ShowNameB>.+))\n";
final String string = "666.Park.Avenue.S01E04.HDTV.x264-LOL.[VTV].mp4\n"
+ "Rick and Morty S01E01 - Pilot [1080p] [h.265].mkv\n"
+ "The.4400.204.mkv\n"
+ "The Flash (2014) - S01E05 - City of Heroes\n"
+ "family.guy.1316.hdtv-lol.mp4\n"
+ "castle.2009.722.hdtv-lol.mp4\n"
+ "Orange.Is.The.New.Black.S01E01.720p.WEBRip.AAC2.0.H.264-Abjex.mkv\n"
+ "Top.Gear.2013.20x03.720p.HDTV.x264-FoV.mkv\n"
+ "archer.2009.S04E13\n"
+ "louie.506.hdtv-lol.mp4\n"
+ "Sense8.S01E05.Art.Is.Like.Religion.WEBRip.x264-SNEAkY.mp4\n"
+ "The.Leftovers.S01E03.HDTV.x264-KILLERS.mp4\n"
+ "space 1999 1975\n"
+ "Top.Gear.20x03.720p.HDTV.x264-FoV.mkv\n"
+ "Space: 1999 (1975)\n"
+ "Space.1999.1975.S01E01\n"
+ "marvels.agents.of.s.h.i.e.l.d.s01e13.720p.hdtv.x264-killers.mkv\n"
+ "Supernatural.S10E12.720p.HDTV.X264-DIMENSION.mkv\n"
+ "12.Monkeys.S01E09.720p.HDTV.x264-KILLERS.mkv\n"
+ "space 1999.(1975)\n"
+ "Space.1999.S01E01\n"
+ "v.2009.S01E13.the.title.avi\n"
+ "Teen.wolf.S04E12.HDTV.x264\n"
+ "The Newsroom 2X04 Conseguenze Indesiderate ITA ENG BDMux -iGM+GiuseppeTnT mkv\n"
+ "Continuum S04E01 Lost Hours -LGC mkv\n"
+ "Royal Pains S07E04 HEVC piemonster mkv\n"
+ "Sense8.S01E05.Art.Is.Like.Religion.WEBRip.x264-SNEAkY.mp4\n"
+ "Family.Guy.S11.Special-200.Episodes.Later.720p.HDTV.X264-DIMENSION";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}